Are you trying to install or update Kodi but receiving a “There was a problem parsing the package” error? Get the details on what it is and how to fix it below.
We’ve had an increase in users confused and frustrated because they are trying to install or update to Kodi 17.1 but are receiving the error message “there was a problem parsing the package”.
This error messages means that your version of Android is not compatible with Kodi 17. Android 4.4 is no longer supported by the newest version of Kodi and you need to have Android 5.1 or higher to install Kodi 17. If you receive the “there was a problem parsing the package error”, you have an unsupported version.
There are a few solutions you may want to consider:
“There was a problem parsing the package” Kodi Solutions
- Buy a new Kodi box. Android 4.4 is 3+ years old and is a legacy product. To ensure that you stay compatible with the newest versions of Kodi, upgrade your Android box. Click here to see our recommend Kodi boxes.
- Install SPMC. SPMC is a fork of Kodi optimized for Android boxes. Worth noting, the release notes of SPMC recommend Android 5.1+ as well (see above) but users using Android 4.4 have reported better compatibility when using SPMC.
Do you think there is another alternative? Let us know so we can pass on the info.
PROTECT YOURSELF ON THE INTERNET
Sign up for a premium Kodi VPN and access the internet unrestricted. We offer exclusive discounts for NordVPN, the highest respected VPN in the Kodi community. It has some great features for users:
Apps for Android, iOS, Mac, Linux & more
Tier 1 hardware (no speed slowdown)
Access to servers hundreds of VPN servers